Device Details

Device Overview

Name/Version: 2RulePictoGramIns1.4 1.2
Author: 2RuleAk100  
Description: Spectrum modifier by using Image.
-Drop an audio sample to the left
-Drop an image to the right
It is recommended that the audio sample has abundant harmonic frequency contents to get a good result
Have e fun with it.
Demo video is in the link
https://youtu.be/F4hUy5aKisA

Update 1.1:
1) Multiple Instance problem fixed.
2) Smoothing (no click) at end points of the looping is improved.

Update 1.2
1)Pict Effect toggle added in order to see the modification of the picture on spectrogram.




 

Device Details

Downloads: 143
Tags synth, glitch, other, beta
Live Version Used: 10.1.18
Max Version Used: 8.1.5
Date Added: Jun 10 2021 14:00:58
Date Last Updated: Jun 16 2021 05:58:40
Average Rating -n/a-
Rate this device: (must be logged in to rate devices login)
Device Type: midi_device
URL (optional): https://youtu.be/F4hUy5aKisA
License (more info): None

Device Files

Device File: 2RulePictoGramIns.amxd
 


Comments

Nice device:)
Couple things:

One is that when you name the matrixes you need to also use the "---" unique identifier because if you load more than one instance of the device in Live they interfere with each other

the second is that you may want to consider some kind of smooth of windowing for the playback. I didnt check thoroughly so I'm not sure what caused it but there is some clicking and popping in the playback.

Otherwise is a wonderful use of fft filtering and sample playback!

Just to clarify if it is helpful for you:

(1) The naming conflicts are noticable when you load another instance and it will start with the spectrogram of the first instance. Also when you trigger voices on one, the sameplayheads appear on other instances too (but that doesnt affect the sound output). there may be other conflicts I didnt see.

(2) clicks occur at end points of the looping (which is where a short fade window could help)

ndivuyo
Many thanks for the guidance and warning.
I will try to fixe the problems you pointed out. I had already set the "wav" variables in buffer~ object with ---. but I missed all the named matrix changes. Thanks again.
Since my max4live version does not have "gen" object development feature, I am trying to develop it in very long ways. Things are geting very complicated in patches and important points can be missed as a result.
It might be better if I upgrade to the gen feature.
I appreciate your detailed response. thanks again

Login to comment on this device.

[ browse device library ]