Device Details

Device Overview

Name/Version: MIDIfilterNOTEmr 0.1
Author: synthesizerwriter  
Description: MIDIfilterNOTEmr is a MIDI note filter or sieve - not the more usual 'filter this type of MIDI message' device. You highlight notes on the graphical keyboards and these noes are then removed from the MIDI stream as it passes through the device. A 'Monitor' mode allows incoming MIDI notes to be viewed - so you can see what to filter out!

More details, applications notes, and an 'inside' view of the M4L are in my blog...
 

Device Details

Downloads: 315
Tags utility, other, beta
Live Version Used: 10.1.3
Max Version Used: 8.1.0
Date Added: Feb 28 2020 14:48:28
Date Last Updated: Mar 23 2020 18:28:31
Average Rating -n/a-
Rate this device: (must be logged in to rate devices login)
Device Type: midi_device
URL (optional): http://blog.synthesizerwriter.com/2020/02/low-latency-midi-note-filter-monitor-in.html
License (more info): None

Device Files

Device File: MIDIfilterNOTEmr_0v01.amxd
 


Comments

Hey!
Presets button not working. also when I load a new template with the device in it it resets my settings and when I add another device to a different channel it resets all of the others.... could be a great device for me if these were fixed.
Thanks!

Oops! Sorry about that. I will have a look.

Curious. I tested all of these functions before releasing the device. So I retested the device (the computer has been rebooted several times since I did the last testing on this device, and I produced MIDIswapNVmr01 on that computer over the last few days).

I tried loading the saved .als file and that worked ok for me. The preset buttons work ok for me. Saving a snapshot of the device works ok for me. I added another device to a different channel and that worked independently of the first channel, with no resetting of the preset memories. I saved the .als file and reloaded it, and everything was ok for me. I added two devices to another channel without any resets in the other devices and they worked, loaded and saved independently for me.

So I'm afraid that I'm having trouble locating the problem at the moment. What version of Ableton Live are you using? What OS are you running?

OK, Update. Just re-tested using Ableton Live 10.1.7. Everything seems to work for me.

Has anyone else had any problems with the presets?

Great device,

Would there be a way where you could do the opposite and have all incoming notes go to a certain notes. so for instance if you had a favourite chord progression that you like, all the incoming notes would be forced into those particular notes .so it would basically be off setting the incoming notes.

Thanks!

Login to comment on this device.

[ browse device library ]